Marqueurs d'approche bugués

Connectez-vous.

Mot de passe oublié ?

Inscrivez-vous.


  • Ce sujet contient 10 réponses, 2 participants et a été mis à jour pour la dernière fois par L3 G33K, le il y a 1 année et 10 mois. This post has been viewed 300 times
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #6043
    L3 G33K
    Participant

    J’ai un gros souci avec les marqueurs d’approche, ils ne s’affichent pas lorsqu’ils sont près de la cible, cf mes récents tweets sur le sujet : https://twitter.com/L3G33K/status/957350201282433025

    Pour ceux qui voudraient bien tester, ci-desous le lien d’une archive avec mon jeu complet, tel que je l’ai laissé, avec mes crafts. Il y a le premier qui a raté et le second pour lequel il m’est impossible de régler un node sans perdre les marqueurs d’approche :
    DS1512+

    #6044
    L3 G33K
    Participant

    https://youtu.be/WJCNreDotKY J’ai fait une vidéo pour illustrer le problème.
    A proximité du Pe, là où je suis censé rencontrer la cible, ils disparaissent, d’un côté comme de l’autre.

    #6127
    Dakitess
    Admin KSC

    Je comprends mieux pourquoi dans tes tweets tu parlais de ton « topic sur KSC » et que je voyais rien apparaitre : la structure des sous-forum bloque les puces « New » rouges, bien utiles…

    Sauf erreur de ma part, nul bug ici : les deux indicateurs t’affichent la position relative de ta cible et de ton module au plus proche en fonction de la manœuvre. Lorsque tu déplaces ton noeud, l’endroit de cette rencontre peut varier du tout au tout, surtout si tu ne touches pas aux poignées colorées pour compenser !

    C’est en tout cas un comportement tout à fait normal de ces indicateurs que j’ai eu dans toutes mes parties. C’est parfois capricieux mais là en l’état tu es loin loin d’avoir une rencontre « au voisinage » et il te faudrait ajuster la manoeuvre pour « confirmer » le point de rencontre le plus évident, et voir les indicateurs se rapprocher sans plus jamais « sauter » vers un autre emplacement puisque ce serait bien la distance relative la plus faible.

    Enfin il me semble ^^ Mais vu d’ici, chaque fois que ça saute c’est pour montrer un écart relatif vraiment similaire, d’ou cette hypothèse d’un deuxième croisement plus loin sur l’orbite qui prend le pas. Un peu comme les indicateurs oranges et violets d’un docking, sauf que là y’a qu’une seule paire disponible et qu’elle est plus tolérante aux distances gigantesques !

    ------------ L'ensemble de mes créations ---------------- Challenge KSC2 - VENERA ! ----------------------- Ma chaîne Youtube ! ----------------------------------

    #6130
    L3 G33K
    Participant

    Bah oui les topics sur KSC c’est bien d’ici dont je parlais ^^

    Dans la vidéo j’ai mis l’exemple en déplaçant le nœud, mais j’ai exactement le même souci en tirant les poignées pour justement réduire l’écart relatif : dès que les marqueurs se rapprochent, ils disparaissent.

    #6132
    L3 G33K
    Participant

    Ah et j’oublais : dans mon autre installation SSRSS (celle dont je tweete régulièrement des screenshots) je n’ai pas ce souci.
    Les deux jeux de base sont strictement identiques (Ctrl+C / Ctrl+V du répertoire Steam installé « à froid »), il n’y a que le pack de mods qui change entre les deux.

    #6207
    Dakitess
    Admin KSC

    Ben je vois pas :s Et le comportement ne me parait pas anormal compte tenu du contexte : par contre tu es peux être dans une config du système solaire bien relou et tu arrives avec une orbite de transfert vraiment pas opti, des intersections franches ! Mais vu comme les distances relatives sont vraiment proches à chaque fois que ça saute, je pense que c’est surtout ce que j’ai dit et que t’as pas de chance dans le placement des planètes et ta trajectoire, avec 3 rencontres potentielles et toutes relativement foireuses : là clairement t’as masse DV a fournir si tu veux choper le premier point devant toi hein ? ^^ Ca m’étonne pas que même en ajustant les points sautent en direction d’un truc plus favorables.

    ------------ L'ensemble de mes créations ---------------- Challenge KSC2 - VENERA ! ----------------------- Ma chaîne Youtube ! ----------------------------------

    #6210
    L3 G33K
    Participant

    J’ai même testé ensuite en foutant un engin sur une orbite héliocentrique circulaire et plane avec Vénus (via le menu AltGr F12). Même souci rencontré.
    Et dans la même situation sur mon autre save, pas de souci. Idem avec ma save « système stock ».

    #6211
    Dakitess
    Admin KSC

    Ha, ça, c’est effectivement quantitatif, si t’as reproduit la même exacte situation et que tu obtiens des résultats différents. Mais ça ne peut pas venir de la Save en elle même puisque, en test croisé, elle n’a impliqué aucun souci chez les autres : peut être une corruption dans les premières minutes de jeu après l’avoir mise ?… Un réglage d’une option, Patch Conics par exemple, etc ?

    ------------ L'ensemble de mes créations ---------------- Challenge KSC2 - VENERA ! ----------------------- Ma chaîne Youtube ! ----------------------------------

    #6212
    L3 G33K
    Participant

    Je n’ai pas de mod permettant de modifier l’affichage des patch conics, comme dans les autres saves 😉
    Je vais laisser tomber l’affaire de toute façon. Je vais sûrement supprimer la save entièrement, et je repartirai d’une installation neuve la prochaine fois.

    #6213
    Dakitess
    Admin KSC

    Ce n’est pas un mod qui permet de modifier les Patch Conics, c’est une option des settings 🙂

    Yep ça marche, c’est sans doute le mieux ^^

    ------------ L'ensemble de mes créations ---------------- Challenge KSC2 - VENERA ! ----------------------- Ma chaîne Youtube ! ----------------------------------

    #6214
    L3 G33K
    Participant

    Ah on peut changer dans les options?
    Je croyais que c’était uniquement accessible via le module « Maneuver Node Editor » de MechJeb ou via d’autres mods spécifiques.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.